[Raspberry Pi] “The following packages have been kept back”

先日 Raspberry Pi のアップデートをした。

$ sudo apt-get update
$ sudo apt-get upgrade

すると以下のように「6つのパッケージがアップデートされていない」(The following packages have been kept back)と表示された。

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
pix-icons pix-plym-splash pixel-wallpaper python-openssl python3-openssl
raspberrypi-ui-mods
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.

これを解消するには、$ sudo apt-get install --reinstall [パッケージ名] とすればいい。

今回の場合は以下のようになる。

$ sudo apt-get install --reinstall pix-icons pix-plym-splash pixel-wallpaper python-openssl python3-openssl raspberrypi-ui-mods

これでアップデートされ、次回からは「アップデートされていない」という文言も出なくなる。

なお、$ sudo apt-get dist-upgrade を実行する方法もあるけれど、そちらはトラブルが発生することがあるので避けたほうがいいみたい。

参考:
apt-get upgrade – packages kept back – Raspberry Pi Forums
https://www.raspberrypi.org/forums/viewtopic.php?t=145870


> 記事のタイトルとURL をコピーする <

書籍